Odd problem. Suggestions please.

I have an odd problem. I turn my Xmitter on then the boat. The sail servo works OK, but the rudder servo does not. It tries to work but just oscillates and jerks around. Sometimes the sail servo does a little jump too without any stick action. I tried to other rudder servos and they do the same. I plugged and unplugged the connector several times and there does not seem to be any corrosion. Could the receiver channel be bad? Any other ideas?

Crystal compatability??


Please measure the battery voltage in the boat when it is turned on and report to us.

Good luck

Try plugging a rudder servo into another slot in the Rx and see if that works. The Rx pins may be corroded.

Don’t think it can be crystals. They match. Have not changed either one since day one. Worked before.

Battery measures 7.04 V to the receiver.

I plugged the rudder servo into another channel and it seems to work OK.

That indicates a bad receiver channel. Odd. I have never had a receiver go bad before.

Anything else to check before I go buy a new receiver?


Could be the TX on that channel or the Rx.

I have some concerns about a 7 Volt supply as that seems high.

I had a few instances of servo chatter when using 4 Lithium (~ 7+ Volts) batteries. I have now switched to 3 lithiums.

What type and number of batteries are you using?

EDIT - Just remembered that I also toasted an HS-55 rudder servo. Not sure if it was the use of 4 Lithiums or not.

Using a 5 pack on Nimh batts. Same battery pack I have been using in the EC-12 for 4 years.

The servo worked fine a few days ago in the shop, but at the lake it started acting up.

I thought I would try a different Transmitter too, so I exchanged xtals with the 2 other Transmitters I have, but nothing would work on the boat with either Transmitter.

If you simply switch rudder and sail connections at the rcvr, does the problem move?

If yes, I would suspect the electronics.
If no, then I would suspect the servo.

It is a strange problem.

Yes, I put the rudder servo in the sail servo spot and the rudder servo worked fine. That led me to believe chan 1 (rudder) of the receiver was bad.

I get the same problem when the receiver or servo gets wet.

You may have a dirty rudder pot in your Tx. Try spraying some electronics cleaner in there and see if it helps.

If that doesn’t work well enough, you might want to dis-assemble the rudder pot and give it a good cleaning…or try swapping the rudder pot with one from a channel that you don’t use.

last week i received 5 futaba radios for the group of kids where i am teaching RC yachting.

One of them just does not work, the servos was jumping intermitently, then they stops and the radio seems to be dead, then they started to move again…
1.- Suspecting any interference i change cristals for the ones i use everyday…the problem continued.

2.- Then i changed the Rx…with the good Xtals…the problem continued.
3.- If i used good Xtals and good Rx…then the bad component is the TX. I placed the radio into the original box and is ready to be shipped to the dealer. They say they will replace it inmediatly, no questions asked.

That is why is importatnt not only to choose a good brand of product, also a good shop or dealer.

Tato Lazo

The problem turned out to be the pot on the TX. I sprayed the pot with contact cleaner and worked it vigorously back and forth. Did the same on the other channel pot as long as I had the TX open.

Rudder servo now works like a charm with no erratic oscillation.

Took my other 2 TXs apart and did the same to them. However one stopped working altogether after reassembly. Be careful how much contact cleaner you use. After using some compressed air to blow out the pot and working it back and forth the TX started working again.

nike shoes